Tutorial: Creating Multi-Column Layouts

This tutorial requires Musink Pro This tutorial will walk you through creating multi-column layouts for exercise books.

Before continuing This tutorial builds on the Your First Template tutorial. If you have not completed the Your First Template tutorial, it is recommended that you complete it before continuing.

In addition, it will be helpful to read information on sections and book publishing before starting this tutorial.

Introduction

Musink does not natively support creating pages made up of two or more columns, but this can be easily performed with the template editor, and an image or PDF editing program. Our plan is to publish each column as its own page, and then to combine pages together using a simple free PDF-editing website. An example image of the outcome is shown below.

A page with two columns created with this tutorial

Create A Template

We are going to create a template using the Musink Pro template editor. When printed to A4 (paper size), our final product will have margins of 20mm, but this process can be adapted to any page or margin size.

Page Sizes Musink Template Editor has minimum page sizes for templates. These exist for good reason, but get in the way of what we are trying to do here. To get around these, we make a template for an A2 (large) sheet of paper. The PDFs you generate can still be viewed on a computer screen and printed onto A4 (smaller) paper without problem. When printed at A4 size, the page will have margins of 20mm.

Final Template Editor Settings
  1. Open (or Restart) Musink and select Start a new Template
  2. Set the units to Millimeters by selecting Millimeters from the top menu under Edit→Units
  3. Set the note size to 140%
  4. Set the page Height to 594
  5. Leave page width set at 210mm
  6. Set the Sections spacing to 36
  7. Select the Odd Pages tab. When prompted, click 'Add'
  8. Set the Left, Top, and Bottom margins to 40
  9. Set the Right, margin to 10
  10. Select the Even Pages tab. When prompted, click 'Add'
  11. Set the Right, margin to 40. Top and Bottom margins should already be 40.
  12. Set the Left margin to 10.
  13. Select the First Page tab then press the delete icon on the far right of the screen
  14. Click File → Save With Preview
  15. When prompted, select Neutral Formality (optional), then Click OK
  16. Save as 'Two Column'. You can ignore any warning message that appears about page width

Our template is now ready.

Note Size We have set note size here to 140%, which will produce medium-sized notes if page is printed on A4 paper. This is entirely optional. If publishing fails because music does not fit on the page, you should edit the template to have a smaller note size.

Publish Your Music

Restart Musink, and write or open your Musink project. Within this project, each exercise should be broken into its own section.

  1. Publish your project by pressing the publish button, or by selecting File → Publish from the menu bar
  2. When the publish options window appears, click the Change… button
  3. When the templates window appears, type the name of your template into the name box
  4. Click Search
  5. Your template should have appeared. Click it then click OK
  6. We want our bars to all be the same length. In the publish window, find Stretch Bars Of Last Row and set to Yes
  7. Optional: Find Space Rows To Maximise Page Use and set to All Pages
  8. Click Publish
  9. Once publishing has completed, choose PDF and save where you would like. If you wish to have bitmap images (PNG), see notes on PNG at the base of this page.

PDF

Our final step is to combine each odd page with the next even page. Luckily, there are online tools for this available.

Warning Musink is not affiliated in any way with the website indicated here and cannot guarantee privacy or safety of these tools. While use is probably safe, doing the next steps are entirely at your own risk. If you are concerned, software the next steps is likely to be available from many other locations online.

  1. Click Browse to select the PDF file of your score
  2. Choose Merge Two Pages Into One - Horizontal
  3. Uncheck Split Line
  4. Click Merge Pages (see warning above)
  5. When it has finished, click Download File and save to your computer
The Final Result

You have now completed the tutorial. Some hints and alternatives are below.

PNG Bitmap Images

If you wish to perform this on PNG images, rather than PDFs, you need to use an image editor to combine your published pages into two-columns. We will use MS Paint to do this here because it is on most Windows installations. There are many free programs available on the internet which are much better than MS Paint for this, such as Paint.NET, Inkscape, and GIMP. With a small amount of practice these can be much faster to use than MS Paint. These instructions are for MS Paint on Windows 10. Steps may differ on other versions of Windows.

Hint Although there appear to be many steps below, these simplify to:

  1. Open the first page,
  2. Resize the canvas,
  3. Copy+Paste the second page to the right of the first page,
  4. Save
  1. Publish to PNG, rather than to PDF, above, then Find your ZIP file containing the published score in Windows Explorer
  2. Right click the ZIP file and select “Extract All…“ and follow the prompts to unzip your files
  3. Open MS Paint
  4. From the top left menu, choose File –> Open and Select 0.PNG (that you have just unzipped)
  5. Press Control+A, then Control+X to cut the image
  6. Click Resize
  7. Uncheck Maintain Aspect Ratio
  8. Ensure the By is set to Percentage then set horizontal to 200
  9. Click OK
  10. Press Control+V to paste the first page back into the image
  11. In Windows Explorer, select 1.PNG from the unzipped folder, then right click and select Edit to open it in a new MS Paint window
  12. In this new MS Paint window, press Control+A then Control+C to copy the image
  13. Close this new MS Paint window
  14. Switch back to the first MS Paint window
  15. Press Control+V then drag the pasted image to the right so that its top right corner is flush with the top right corner of the page
  16. Save your new file by choosing File–>Save As then selecting PNG
Print/export